首页 ? git ? 解决centos、redhat等git版本过低的办法——centos6.5 安装git

解决centos、redhat等git版本过低的办法——centos6.5 安装git

添加评论 次下载365游戏棋牌游戏_365棋牌辅助透视好用吗_365手游棋牌免费送金币

【提示】 非法信息举报请联系本站小编 QQ:5.4069748.5

本文来自网络,原文链接:http://www.cnblogs.com/fuyuanming/p/5804695.html

1.安装编译git时需要的包

#?yum?install?curl-devel?expat-devel?gettext-devel?openssl-devel?zlib-devel

#?yum?install??gcc?perl-ExtUtils-MakeMaker

2.删除已有的git

#?yum?remove?git

3.下载git源码

#?cd?/usr/src
#?wget?https://www.kernel.org/pub/software/scm/git/git-2.0.5.tar.gz#?tar?xzf?git-2.0.5.tar.gz

4.编译安装

#?cd?git-2.0.5#?make?prefix=/usr/local/git?all
#?make?prefix=/usr/local/git?install
#?echo?"export?PATH=$PATH:/usr/local/git/bin"?>>?/etc/bashrc
#?source?/etc/bashrc

5.检查一下版本号

#?git?--version